Fix hacking min version to 3.0.1

flake8 new release 3.8.0 added new checks and gate pep8
job start failing. hacking 3.0.1 fix the pinning of flake8 to
avoid bringing in a new version with new checks.

Though it is fixed in latest hacking but 2.0 and 3.0 has cap for
flake8 as <4.0.0 which mean flake8 new version 3.9.0 can also
break the pep8 job if new check are added.

To avoid similar gate break in future, we need to bump the hacking min
version.

Also removing the hacking and other related dep from lower-constraints file
as theose are blacklisted requirements and does not need to be present
there.

- http://lists.openstack.org/pipermail/openstack-discuss/2020-May/014828.html

Change-Id: Icbbd8370dd24882b34e3616030ad4dedd1d565a0
(cherry picked from commit b63a85aa5b)
changes/47/728947/1
Ghanshyam Mann 3 years ago committed by Lee Yarwood
parent 396fe1a5ab
commit dfd835e3d6
  1. 4
      lower-constraints.txt
  2. 2
      test-requirements.txt

@ -16,10 +16,8 @@ eventlet==0.18.2
extras==1.0.0
fasteners==0.7.0
fixtures==3.0.0
flake8==2.5.5
future==0.16.0
greenlet==0.4.10
hacking==2.0.0
idna==2.6
imagesize==0.7.1
iso8601==0.1.11
@ -53,10 +51,8 @@ oslotest==3.2.0
Paste==2.0.2
PasteDeploy==1.5.0
pbr==2.0.0
pep8==1.5.7
prettytable==0.7.2
pycparser==2.18
pyflakes==0.8.1
Pygments==2.2.0
pyinotify==0.9.6
pyparsing==2.1.0

@ -2,7 +2,7 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
hacking>=2.0.0 # Apache-2.0
hacking>=3.0.1,<3.1.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
ddt>=1.0.1 # MIT
reno>=2.5.0 # Apache-2.0

Loading…
Cancel
Save