Browse Source

Cleanup py27 support

Make a few cleanups:
- Remove python 2.7 stanza from setup.py
- Add requires on python >= 3.6 to setup.cfg so that pypi and pip
  know about the requirement
- Remove obsolete sections from setup.cfg:
  * Wheel is not needed for python 3 only repo
- Update classifiers
- Update requirements, no need for python_version anymore

Change-Id: Ibcee6e71253fceb4c46442646a99f3b58e9df26d
changes/68/717568/1
Andreas Jaeger 4 months ago
parent
commit
2d6a97498e
3 changed files with 5 additions and 15 deletions
  1. +4
    -4
      setup.cfg
  2. +0
    -9
      setup.py
  3. +1
    -2
      test-requirements.txt

+ 4
- 4
setup.cfg View File

@@ -5,7 +5,8 @@ author-email = openstack-discuss@lists.openstack.org
summary = Refresh system configuration
description-file =
README.rst
home-page = http://github.com/openstack/os-refresh-config
home-page = http://opendev.org/openstack/os-refresh-config
python-requires = >=3.6
classifier =
Development Status :: 4 - Beta
Environment :: Console
@@ -15,6 +16,8 @@ classifier =
License :: OSI Approved :: Apache Software License
Operating System :: OS Independent
Programming Language :: Python
Programming Language :: Python :: Implementation :: CPython
Programming Language :: Python :: 3 :: Only
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
@@ -31,6 +34,3 @@ console_scripts =
tag_build =
tag_date = 0
tag_svn_revision = 0

[wheel]
universal = 1

+ 0
- 9
setup.py View File

@@ -13,17 +13,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.

# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools

# In python < 2.7.4, a lazy loading of package `pbr` will break
# setuptools if some other modules registered functions in `atexit`.
# solution from: http://bugs.python.org/issue15881#msg170215
try:
import multiprocessing # noqa
except ImportError:
pass

setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)

+ 1
- 2
test-requirements.txt View File

@@ -6,8 +6,7 @@ hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
fixtures>=3.0.0 # Apache-2.0/BSD
python-subunit>=1.0.0 # Apache-2.0/BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2,<2.0.0;python_version=='2.7' # BSD
sphinx!=1.6.6,!=1.6.7,!=2.1.0,>=1.6.2;python_version>='3.4' # BSD
sphinx!=1.6.6,!=1.6.7,!=2.1.0,>=1.6.2 # BSD
stestr>=2.0.0 # Apache-2.0
testscenarios>=0.4 # Apache-2.0/BSD
testtools>=2.2.0 # MIT

Loading…
Cancel
Save