Remove tripleo-multinode-container-minimal from layout + fix test

The tripleo-multinode-container-minimal is being deprecated [1]
as part of wider tripleo CI optimization at [2].

This updates test-requirements to fix issue seen in [3] and also
fixes a failing pep8 test seen after test-requirements was fixed.

[1] Ie6473759383bd4b903cbe56fba9fee75a24154c4
[2] https://review.opendev.org/q/topic:tripleo-ci-reduce
[3] https://a28720641abd1053931d-69746c322fe5e3cf8e2976f654b96d92.ssl.cf5.rackcdn.com/777098/1/check/openstack-tox-py38/9e6a3c0/tox/py38-1.log

Change-Id: I6df7ef9eacc25435e797005ad8f764c3e0913d46
changes/98/777098/3
Marios Andreou 2 years ago
parent 754bb751e6
commit a0322979f9

@ -33,6 +33,6 @@ class TestRefreshConfig(testtools.TestCase):
def test_default_base_dir_both(self):
default = '/usr/libexec/os-refresh-config'
deprecated = '/opt/stack/os-config-refresh'
with mock.patch('os.path.isdir', lambda x: (x == default or
x == deprecated)):
with mock.patch('os.path.isdir', lambda x: (
x == default or x == deprecated)):
self.assertEqual(default, os_refresh_config.default_base_dir())

@ -1,8 +1,7 @@
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
hacking>=3.0.1,<3.1.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
fixtures>=3.0.0 # Apache-2.0/BSD
python-subunit>=1.0.0 # Apache-2.0/BSD
@ -10,4 +9,3 @@ sphinx!=1.6.6,!=1.6.7,!=2.1.0,>=1.6.2 # BSD
stestr>=2.0.0 # Apache-2.0
testscenarios>=0.4 # Apache-2.0/BSD
testtools>=2.2.0 # MIT
pyflakes>=2.2.0

@ -3,4 +3,3 @@
- check-requirements
- openstack-cover-jobs
- openstack-python3-ussuri-jobs
- tripleo-multinode-container-minimal

Loading…
Cancel
Save