Browse Source

fix lower constraints and uncap eventlet

Fix the lower constraints settings to match the expected values.

We will manage the eventlet version using constraints now. See the
thread starting at
http://lists.openstack.org/pipermail/openstack-dev/2018-April/129096.html
for more details.

Change-Id: I9b2cdb68fd87e07d9ae0226bc2c1d77d6981ef52
Signed-off-by: Doug Hellmann <doug@doughellmann.com>
Doug Hellmann 1 year ago
parent
commit
1bd8ac4269
2 changed files with 5 additions and 3 deletions
  1. 4
    2
      lower-constraints.txt
  2. 1
    1
      test-requirements.txt

+ 4
- 2
lower-constraints.txt View File

@@ -1,16 +1,18 @@
1 1
 alabaster==0.7.10
2 2
 appdirs==1.3.0
3 3
 Babel==2.3.4
4
-bandit==1.4.0
4
+bandit==1.1.0
5 5
 coverage==4.0
6 6
 debtcollector==1.2.0
7 7
 docutils==0.11
8 8
 dulwich==0.15.0
9
+enum34==1.0.4;python_version=='2.7' or python_version=='2.6' or python_version=='3.3' # BSD
9 10
 eventlet==0.18.2
10 11
 extras==1.0.0
11 12
 fasteners==0.7.0
12 13
 fixtures==3.0.0
13 14
 flake8==2.5.5
15
+futures==3.0.0;python_version=='2.7' or python_version=='2.6' # BSD
14 16
 gitdb==0.6.4
15 17
 GitPython==1.0.1
16 18
 greenlet==0.4.10
@@ -49,7 +51,7 @@ rfc3986==0.3.1
49 51
 six==1.10.0
50 52
 smmap==0.9.0
51 53
 snowballstemmer==1.2.1
52
-Sphinx==1.6.5
54
+Sphinx==1.6.2
53 55
 sphinxcontrib-websupport==1.0.1
54 56
 stevedore==1.20.0
55 57
 testrepository==0.0.18

+ 1
- 1
test-requirements.txt View File

@@ -13,7 +13,7 @@ openstackdocstheme>=1.18.1 # Apache-2.0
13 13
 sphinx!=1.6.6,!=1.6.7,>=1.6.2 # BSD
14 14
 reno>=2.5.0 # Apache-2.0
15 15
 
16
-eventlet!=0.18.3,!=0.20.1,<0.21.0,>=0.18.2 # MIT
16
+eventlet!=0.18.3,!=0.20.1,>=0.18.2 # MIT
17 17
 
18 18
 # Bandit security code scanner
19 19
 bandit>=1.1.0 # Apache-2.0

Loading…
Cancel
Save