Browse Source

Update hacking version

Use latest release 1.1.0 and compatible changes w.r.t pep8

Change-Id: Iec0c74ab679d6046b12f1d16ecd5cb6dfa74b3ed
tags/3.29.1
ZhijunWei 7 months ago
parent
commit
3ea7c472cf
3 changed files with 6 additions and 8 deletions
  1. 2
    2
      README.rst
  2. 3
    5
      oslo_concurrency/opts.py
  3. 1
    1
      test-requirements.txt

+ 2
- 2
README.rst View File

@@ -7,9 +7,9 @@ Team and repository tags
7 7
 
8 8
 .. Change things from this point on
9 9
 
10
-==================
10
+=================
11 11
  oslo.concurrency
12
-==================
12
+=================
13 13
 
14 14
 .. image:: https://img.shields.io/pypi/v/oslo.concurrency.svg
15 15
     :target: https://pypi.org/project/oslo.concurrency/

+ 3
- 5
oslo_concurrency/opts.py View File

@@ -12,17 +12,15 @@
12 12
 #    License for the specific language governing permissions and limitations
13 13
 #    under the License.
14 14
 
15
+import copy
16
+
17
+from oslo_concurrency import lockutils
15 18
 
16 19
 __all__ = [
17 20
     'list_opts',
18 21
 ]
19 22
 
20 23
 
21
-import copy
22
-
23
-from oslo_concurrency import lockutils
24
-
25
-
26 24
 def list_opts():
27 25
     """Return a list of oslo.config options available in the library.
28 26
 

+ 1
- 1
test-requirements.txt View File

@@ -2,7 +2,7 @@
2 2
 # of appearance. Changing the order has an impact on the overall integration
3 3
 # process, which may cause wedges in the gate later.
4 4
 
5
-hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
5
+hacking>=1.1.0,<1.2.0 # Apache-2.0
6 6
 oslotest>=3.2.0 # Apache-2.0
7 7
 coverage!=4.4,>=4.0 # Apache-2.0
8 8
 futures>=3.0.0;python_version=='2.7' or python_version=='2.6' # BSD

Loading…
Cancel
Save