Browse Source

set default python to python3

Set the default python to python3 except for the py27 environment. We
have to set that explicitly to override the new default.

Change-Id: I3fa047b21fa6bc6e5bdf3222287fdce31c5ccef2
Signed-off-by: Doug Hellmann <doug@doughellmann.com>
Doug Hellmann 1 year ago
parent
commit
b2c131076a
1 changed files with 4 additions and 2 deletions
  1. 4
    2
      tox.ini

+ 4
- 2
tox.ini View File

@@ -3,6 +3,7 @@ minversion = 2.0
3 3
 envlist = py35,py27,pep8
4 4
 
5 5
 [testenv]
6
+basepython = python3
6 7
 install_command = pip install {opts} {packages}
7 8
 deps =
8 9
   -c{env:UPPER_CONSTRAINTS_FILE:https://git.openstack.org/cgit/openstack/requirements/plain/upper-constraints.txt}
@@ -13,8 +14,10 @@ commands =
13 14
     lockutils-wrapper python setup.py testr --slowest --testr-args='{posargs}'
14 15
     env TEST_EVENTLET=1 lockutils-wrapper python setup.py testr --slowest --testr-args='{posargs}'
15 16
 
17
+[testenv:py27]
18
+basepython = python2.7
19
+
16 20
 [testenv:pep8]
17
-basepython = python3
18 21
 deps =
19 22
   -r{toxinidir}/test-requirements.txt
20 23
 commands =
@@ -52,7 +55,6 @@ commands = pip-missing-reqs -d --ignore-module=oslo_concurrency* --ignore-file=o
52 55
 commands = sphinx-build -a -E -W -d releasenotes/build/doctrees -b html releasenotes/source releasenotes/build/html
53 56
 
54 57
 [testenv:lower-constraints]
55
-basepython = python3
56 58
 deps =
57 59
   -c{toxinidir}/lower-constraints.txt
58 60
   -r{toxinidir}/test-requirements.txt

Loading…
Cancel
Save