Browse Source

Merge "[goal] Migrate testing to ubuntu focal"

tags/12.5.0^0
Zuul 2 weeks ago
committed by Gerrit Code Review
parent
commit
62e104bdb5
4 changed files with 13 additions and 13 deletions
  1. +8
    -8
      lower-constraints.txt
  2. +1
    -1
      requirements.txt
  3. +1
    -1
      setup.cfg
  4. +3
    -3
      test-requirements.txt

+ 8
- 8
lower-constraints.txt View File

@@ -4,34 +4,34 @@ appdirs==1.3.0
Babel==2.3.4
bandit==1.1.0
cachetools==2.0.0
cffi==1.7.0
cffi==1.14.0
cliff==2.8.0
cmd2==0.8.0
confluent-kafka==0.11.6
confluent-kafka==1.3.0
contextlib2==0.4.0
coverage==4.0
debtcollector==1.2.0
docutils==0.11
dulwich==0.15.0
eventlet==0.18.2
eventlet==0.23.0
extras==1.0.0
fasteners==0.7.0
fixtures==3.0.0
futurist==1.2.0
gitdb==0.6.4
GitPython==1.0.1
greenlet==0.4.10
greenlet==0.4.15
imagesize==0.7.1
iso8601==0.1.11
Jinja2==2.10
keystoneauth1==3.4.0
kombu==4.6.6
linecache2==1.0.0
MarkupSafe==1.0
MarkupSafe==1.1.1
mock==2.0.0
mox3==0.20.0
msgpack-python==0.4.0
netaddr==0.7.18
netaddr==0.8.0
netifaces==0.10.4
os-client-config==1.28.0
oslo.concurrency==3.25.0
@@ -57,10 +57,10 @@ pyparsing==2.1.0
pyperclip==1.5.27
python-dateutil==2.5.3
python-mimeparse==1.6.0
python-qpid-proton==0.17.0
python-qpid-proton==0.20.0
python-subunit==1.0.0
pytz==2013.6
PyYAML==3.12
PyYAML==3.13
repoze.lru==0.7
requests==2.14.2
requestsexceptions==1.2.0


+ 1
- 1
requirements.txt View File

@@ -19,7 +19,7 @@ cachetools>=2.0.0 # MIT License
WebOb>=1.7.1 # MIT

# for the routing notifier
PyYAML>=3.12 # MIT
PyYAML>=3.13 # MIT

# rabbit driver is the default
# we set the amqp version to ensure heartbeat works


+ 1
- 1
setup.cfg View File

@@ -28,7 +28,7 @@ classifier =
amqp1 =
pyngus>=2.2.0 # Apache-2.0
kafka =
confluent-kafka>=0.11.6 # Apache-2.0
confluent-kafka>=1.3.0 # Apache-2.0

[files]
packages =


+ 3
- 3
test-requirements.txt View File

@@ -13,7 +13,7 @@ oslotest>=3.2.0 # Apache-2.0
pifpaf>=2.2.0 # Apache-2.0

# for test_impl_kafka
confluent-kafka>=0.11.6 # Apache-2.0
confluent-kafka>=1.3.0 # Apache-2.0

# when we can require tox>= 1.4, this can go into tox.ini:
# [testenv:cover]
@@ -27,5 +27,5 @@ pyngus>=2.2.0 # Apache-2.0
# Bandit security code scanner
bandit>=1.6.0,<1.7.0 # Apache-2.0

eventlet!=0.18.3,!=0.20.1,>=0.18.2 # MIT
greenlet>=0.4.10 # MIT
eventlet>=0.23.0 # MIT
greenlet>=0.4.15 # MIT

Loading…
Cancel
Save