OpenStack library for messaging
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

requirements.txt 918B

123456789101112131415161718192021222324252627282930313233
  1. # The order of packages is significant, because pip processes them in the order
  2. # of appearance. Changing the order has an impact on the overall integration
  3. # process, which may cause wedges in the gate later.
  4. pbr!=2.1.0,>=2.0.0 # Apache-2.0
  5. futurist>=1.2.0 # Apache-2.0
  6. oslo.config>=5.2.0 # Apache-2.0
  7. oslo.log>=3.36.0 # Apache-2.0
  8. oslo.utils>=3.33.0 # Apache-2.0
  9. oslo.serialization!=2.19.1,>=2.18.0 # Apache-2.0
  10. oslo.service!=1.28.1,>=1.24.0 # Apache-2.0
  11. oslo.i18n>=3.15.3 # Apache-2.0
  12. stevedore>=1.20.0 # Apache-2.0
  13. debtcollector>=1.2.0 # Apache-2.0
  14. monotonic>=0.6;python_version<'3.3' # Apache-2.0
  15. # for jsonutils
  16. six>=1.10.0 # MIT
  17. cachetools>=2.0.0 # MIT License
  18. WebOb>=1.7.1 # MIT
  19. # for the routing notifier
  20. PyYAML>=3.12 # MIT
  21. # rabbit driver is the default
  22. # we set the amqp version to ensure heartbeat works
  23. amqp>=2.4.1 # BSD
  24. kombu!=4.0.2,>=4.0.0 # BSD
  25. # middleware
  26. oslo.middleware>=3.31.0 # Apache-2.0