Browse Source

fix lower constraints and uncap eventlet

Fix the lower constraints values to match the expected values.

We will manage the eventlet version using constraints now. See the
thread starting at
http://lists.openstack.org/pipermail/openstack-dev/2018-April/129096.html
for more details.

Update msgpack to >=0.5.0 because 0.4.0 is no longer available on PyPI
and we need the lower bound to match the lower constraint.

Change-Id: Ic692cc024bc60b1913fb9eac60be92f7dd353a89
Signed-off-by: Doug Hellmann <doug@doughellmann.com>
Doug Hellmann 1 year ago
parent
commit
d5d486faed
2 changed files with 6 additions and 5 deletions
  1. 4
    3
      lower-constraints.txt
  2. 2
    2
      requirements.txt

+ 4
- 3
lower-constraints.txt View File

@@ -1,11 +1,12 @@
1 1
 alabaster==0.7.10
2 2
 appdirs==1.3.0
3 3
 Babel==2.3.4
4
-bandit==1.4.0
4
+bandit==1.1.0
5 5
 cffi==1.7.0
6 6
 debtcollector==1.2.0
7 7
 docutils==0.11
8 8
 dulwich==0.15.0
9
+enum34==1.0.4;python_version=='2.7' or python_version=='2.6' or python_version=='3.3' # BSD
9 10
 eventlet==0.18.2
10 11
 extras==1.0.0
11 12
 fixtures==3.0.0
@@ -24,8 +25,8 @@ mccabe==0.2.1
24 25
 mock==2.0.0
25 26
 monotonic==0.6
26 27
 mox3==0.20.0
27
-msgpack==0.5.1
28 28
 msgpack-python==0.4.0
29
+msgpack==0.5.0
29 30
 netaddr==0.7.18
30 31
 netifaces==0.10.4
31 32
 openstackdocstheme==1.18.1
@@ -56,7 +57,7 @@ rfc3986==0.3.1
56 57
 six==1.10.0
57 58
 smmap==0.9.0
58 59
 snowballstemmer==1.2.1
59
-Sphinx==1.6.5
60
+Sphinx==1.6.2
60 61
 sphinxcontrib-websupport==1.0.1
61 62
 stevedore==1.20.0
62 63
 testrepository==0.0.18

+ 2
- 2
requirements.txt View File

@@ -8,6 +8,6 @@ oslo.config>=5.2.0 # Apache-2.0
8 8
 oslo.utils>=3.33.0 # Apache-2.0
9 9
 enum34>=1.0.4;python_version=='2.7' or python_version=='2.6' or python_version=='3.3' # BSD
10 10
 cffi>=1.7.0 # MIT
11
-eventlet!=0.18.3,!=0.20.1,<0.21.0,>=0.18.2 # MIT
11
+eventlet!=0.18.3,!=0.20.1,>=0.18.2 # MIT
12 12
 greenlet>=0.4.10 # MIT
13
-msgpack>=0.4.0 # Apache-2.0
13
+msgpack>=0.5.0 # Apache-2.0

Loading…
Cancel
Save