Browse Source

add lower-constraints job

Create a tox environment for running the unit tests against the lower
bounds of the dependencies.

Create a lower-constraints.txt to be used to enforce the lower bounds
in those tests.

Add openstack-tox-lower-constraints job to the zuul configuration.

See http://lists.openstack.org/pipermail/openstack-dev/2018-March/128352.html
for more details.

Change-Id: I161c55335b8fa6a57164bfadbc7be0adb6fed33b
Depends-On: https://review.openstack.org/555034
Signed-off-by: Doug Hellmann <doug@doughellmann.com>
tags/1.28.0
Doug Hellmann 1 year ago
parent
commit
a3ee768864
3 changed files with 75 additions and 0 deletions
  1. 7
    0
      .zuul.yaml
  2. 61
    0
      lower-constraints.txt
  3. 7
    0
      tox.ini

+ 7
- 0
.zuul.yaml View File

@@ -0,0 +1,7 @@
1
+- project:
2
+    check:
3
+      jobs:
4
+        - openstack-tox-lower-constraints
5
+    gate:
6
+      jobs:
7
+        - openstack-tox-lower-constraints

+ 61
- 0
lower-constraints.txt View File

@@ -0,0 +1,61 @@
1
+alabaster==0.7.10
2
+appdirs==1.3.0
3
+Babel==2.3.4
4
+bandit==1.4.0
5
+coverage==4.0
6
+debtcollector==1.2.0
7
+docutils==0.11
8
+dulwich==0.15.0
9
+eventlet==0.18.2
10
+extras==1.0.0
11
+fixtures==3.0.0
12
+flake8==2.5.5
13
+gitdb==0.6.4
14
+GitPython==1.0.1
15
+greenlet==0.4.10
16
+hacking==0.12.0
17
+imagesize==0.7.1
18
+iso8601==0.1.11
19
+Jinja2==2.10
20
+keystoneauth1==3.4.0
21
+linecache2==1.0.0
22
+MarkupSafe==1.0
23
+mccabe==0.2.1
24
+mock==2.0.0
25
+monotonic==0.6
26
+mox3==0.20.0
27
+msgpack-python==0.4.0
28
+netaddr==0.7.18
29
+netifaces==0.10.4
30
+openstackdocstheme==1.18.1
31
+os-client-config==1.28.0
32
+oslo.config==5.2.0
33
+oslo.i18n==3.15.3
34
+oslo.serialization==2.18.0
35
+oslo.utils==3.33.0
36
+oslotest==3.2.0
37
+pbr==2.0.0
38
+pep8==1.5.7
39
+psutil==3.2.2
40
+pyflakes==0.8.1
41
+Pygments==2.2.0
42
+pyparsing==2.1.0
43
+python-mimeparse==1.6.0
44
+python-subunit==1.0.0
45
+pytz==2013.6
46
+PyYAML==3.12
47
+reno==2.5.0
48
+requests==2.14.2
49
+requestsexceptions==1.2.0
50
+rfc3986==0.3.1
51
+six==1.10.0
52
+smmap==0.9.0
53
+snowballstemmer==1.2.1
54
+Sphinx==1.6.5
55
+sphinxcontrib-websupport==1.0.1
56
+stevedore==1.20.0
57
+testrepository==0.0.18
58
+testtools==2.2.0
59
+traceback2==1.4.0
60
+unittest2==1.1.0
61
+wrapt==1.7.0

+ 7
- 0
tox.ini View File

@@ -47,3 +47,10 @@ commands = pip-missing-reqs -d --ignore-module=oslo_reports* --ignore-module=pkg
47 47
 
48 48
 [testenv:releasenotes]
49 49
 commands = sphinx-build -a -E -W -d releasenotes/build/doctrees -b html releasenotes/source releasenotes/build/html
50
+
51
+[testenv:lower-constraints]
52
+basepython = python3
53
+deps =
54
+  -c{toxinidir}/lower-constraints.txt
55
+  -r{toxinidir}/test-requirements.txt
56
+  -r{toxinidir}/requirements.txt

Loading…
Cancel
Save