Browse Source

Fix testenv

Change-Id: Id366a7b47c9ae94a0272451ba2d2cd26926bb094
changes/22/466922/1
Steve Baker 4 years ago
parent
commit
c4a016465b
3 changed files with 12 additions and 14 deletions
  1. +2
    -2
      requirements.txt
  2. +3
    -3
      test-requirements.txt
  3. +7
    -9
      tox.ini

+ 2
- 2
requirements.txt View File

@ -2,6 +2,6 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
pbr>=1.8 # Apache-2.0
pbr>=2.0.0,!=2.1.0 # Apache-2.0
cliff>=1.4
cliff>=2.6.0 # Apache-2.0

+ 3
- 3
test-requirements.txt View File

@ -2,11 +2,11 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
hacking>=0.12.0,<0.13 # Apache-2.0
hacking>=0.12.0,!=0.13.0,<0.14 # Apache-2.0
coverage>=4.0 # Apache-2.0
coverage>=4.0,!=4.4 # Apache-2.0
python-subunit>=0.0.18 # Apache-2.0/BSD
sphinx>=1.2.1,!=1.3b1,<1.4 # BSD
sphinx>=1.5.1,!=1.6.1 # BSD
oslosphinx>=4.7.0 # Apache-2.0
oslotest>=1.10.0 # Apache-2.0
testrepository>=0.0.18 # Apache-2.0/BSD


+ 7
- 9
tox.ini View File

@ -1,16 +1,14 @@
[tox]
minversion = 2.0
envlist = py34,py27,pypy,pep8
envlist = py35,py27,pep8
skipsdist = True
[testenv]
usedevelop = True
install_command = pip install -c{env:UPPER_CONSTRAINTS_FILE:https://git.openstack.org/cgit/openstack/requirements/plain/upper-constraints.txt} {opts} {packages}
setenv =
VIRTUAL_ENV={envdir}
PYTHONWARNINGS=default::DeprecationWarning
deps = -r{toxinidir}/test-requirements.txt
commands = python setup.py test --slowest --testr-args='{posargs}'
setenv = VIRTUAL_ENV={envdir}
deps = -r{toxinidir}/requirements.txt
-r{toxinidir}/test-requirements.txt
commands = bash -c 'if [ ! -d ./.testrepository ] ; then testr init ; fi'
testr run {posargs}
[testenv:pep8]
commands = flake8 {posargs}


Loading…
Cancel
Save