Browse Source

Don't install python-dev on focal

Also, install yamllint in the dib env, as it's a requirement
of dib-lint now but is only in test-requirements for dib.

Change-Id: I083bca901ca51438099d1d3bbbd0076ac3d7da07
changes/37/731237/2
Monty Taylor 2 years ago
parent
commit
0a4e2aab9a
  1. 3
      nodepool/elements/infra-package-needs/pkg-map
  2. 1
      tox.ini

3
nodepool/elements/infra-package-needs/pkg-map

@ -10,7 +10,8 @@
"ubuntu": {
"focal": {
"ntp": "",
"ntpdate": ""
"ntpdate": "",
"python-dev": ""
}
}
},

1
tox.ini

@ -109,6 +109,7 @@ commands = {toxinidir}/specs/generate_specs_site.py {toxinidir}/specs/specs.yaml
[testenv:dib]
deps =
diskimage-builder
yamllint
changedir = {toxinidir}/nodepool
commands = env ELEMENTS_DIR=elements dib-lint

Loading…
Cancel
Save