Browse Source

infra-pkg-needs: Update pkg-maps for CentOS 8, select chronyd

These images are Python3 only -- no python-dev

The ntp tools are replaced with chrony on CentOS 8, select it instead.
Update the service enablement too.  I have done a quick audit and
I don't believe any of our base job parts rely on ntpdate as such
(except for deprecated devstack-gate; there is actually an
unmerged ancient change! [1]).

[1] https://review.opendev.org/#/c/352674/1/functions.sh

Change-Id: Id2dbda7f114de0be4e4227da179490a17a22eb24
changes/45/687445/1
Ian Wienand 3 years ago
parent
commit
5a649ce32d
  1. 9
      nodepool/elements/infra-package-needs/pkg-map
  2. 2
      nodepool/elements/infra-package-needs/post-install.d/80-enable-infra-services

9
nodepool/elements/infra-package-needs/pkg-map

@ -1,4 +1,13 @@
{
"release": {
"centos": {
"8": {
"python-dev": "",
"ntp": "chrony",
"ntpdate": ""
}
}
},
"distro": {
"fedora": {
"python3-dev": "python3-devel",

2
nodepool/elements/infra-package-needs/post-install.d/80-enable-infra-services

@ -14,6 +14,8 @@ case "$DIB_INIT_SYSTEM" in
systemd)
if [[ $DISTRO_NAME = "ubuntu" || $DISTRO_NAME = "debian" ]]; then
systemctl enable ntp.service
elif [[ $DISTRO_NAME == "centos" && $DIB_RELEASE -ge 8 ]]; then
systemctl enable chronyd
else
systemctl enable ntpd.service
fi

Loading…
Cancel
Save