Browse Source

tox.ini : update Ansible pin

ansible-lint is incompatible with Ansible 2.7 which is now causing
failures.  Update to current Zuul versions.

Change-Id: I65878a896281ad67d512f0bd9219aa2058e4953a
changes/73/761473/1
Ian Wienand 8 months ago
parent
commit
a531d83bac
1 changed files with 5 additions and 3 deletions
  1. +5
    -3
      tox.ini

+ 5
- 3
tox.ini View File

@ -26,9 +26,11 @@ setenv =
# Add dependencies here since other jobs use python2 and zuul requires
# python3.
deps =
# Pin ansible to common version we use, otherwise ansible-lint
# would pull in latest version.
ansible>=2.7.0,<2.8
# ansible-lint brings in the latest version of ansible, but we
# keep this in sync with what Zuul uses so we don't allow though
# things from a later ansible that would actually fail in
# production.
ansible>=2.8,<=2.9
ansible-lint>=4.2.0,<5
hacking>=2.0.0,<2.1.0
bashate>=0.2


Loading…
Cancel
Save