Configuration files for project CI systems
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 

114 lines
3.7 KiB

# This is the fallback list for packages to install. Do not add
# additional packages here. Repositories should use bindep and create
# their own bindep.txt files if the list below is not
# working for them.
build-essential [platform:dpkg]
curl [!platform:gentoo]
net-misc/curl [platform:gentoo]
dev-libs/cyrus-sasl [platform:gentoo]
cyrus-sasl-devel [platform:rpm]
media-fonts/nanumfont [platform:gentoo]
fonts-nanum [platform:dpkg]
media-fonts/takao-fonts [platform:gentoo]
fonts-takao [platform:dpkg]
gawk
gettext [!platform:suse]
gettext-runtime [platform:suse]
graphviz [!platform:gentoo]
media-gfx/graphviz [platform:gentoo]
language-pack-en [platform:ubuntu]
libcurl-devel [platform:rpm]
libcurl4-gnutls-dev [platform:dpkg]
libevent-dev [platform:dpkg]
libevent-devel [platform:rpm]
dev-libs/libevent [platform:gentoo]
libffi-dev [platform:dpkg]
libffi-devel [platform:redhat platform:suse]
virtual/libffi [platform:gentoo]
libjerasure-dev [platform:ubuntu]
dev-libs/jerasure [platform:gentoo]
libjpeg-dev [platform:dpkg]
libjpeg8-devel [platform:suse]
libjpeg-turbo-devel [platform:redhat]
media-libs/libjpeg-turbo [platform:gentoo]
libldap2-dev [platform:dpkg]
net-nds/openldap [platform:gentoo]
libmysqlclient-dev [platform:dpkg]
libpcap-dev [platform:dpkg]
libpcap-devel [platform:rpm]
net-libs/libpcap [platform:gentoo]
libpq-dev [platform:dpkg]
librrd-dev [platform:dpkg]
net-analyzer/rrdtool [platform:gentoo]
libsasl2-dev [platform:dpkg]
libselinux-python [platform:redhat]
python-selinux [platform:suse]
sys-libs/libselinux [platform:gentoo]
libsqlite3-dev [platform:dpkg]
libuuid-devel [platform:rpm]
libvirt-dev [platform:dpkg]
libvirt-devel [platform:rpm]
app-emulation/libvirt [platform:gentoo]
libvirt-python [platform:rpm]
dev-python/libvirt-python [platform:gentoo]
libxml2-dev [platform:dpkg]
libxml2-devel [platform:rpm]
libxml2-utils [platform:dpkg]
dev-libs/libxml2 [platform:gentoo]
libxslt-devel [platform:rpm]
libxslt1-dev [platform:dpkg]
dev-libs/libxslt [platform:gentoo]
locales [platform:debian]
mariadb [platform:rpm]
mariadb-server [platform:redhat]
mariadb-devel [platform:redhat]
libmysqlclient-devel [platform:suse]
dev-db/mariadb [platform:gentoo]
memcached
mysql-client [platform:dpkg]
mysql-server [platform:dpkg]
openldap-devel [platform:redhat]
openldap2-devel [platform:suse]
pkg-config [platform:dpkg platform:suse]
pkgconfig [platform:redhat]
virtual/pkgconfig [platform:gentoo]
postgresql
postgresql-client [platform:dpkg]
postgresql-devel [platform:rpm]
postgresql-server [platform:rpm]
pypy [platform:ubuntu]
pypy-dev [platform:ubuntu]
python-dev [platform:dpkg]
python-devel [platform:rpm]
dev-lang/python [platform:gentoo]
python-libvirt [platform:dpkg]
python-lxml [!platform:gentoo !platform:fedora]
python2-lxml [platform:fedora]
dev-python/lxml [platform:gentoo]
# Note that python3-all-dev includes python3-all, added
# both here for documentary purpose.
python3-all [platform:dpkg]
python3-all-dev [platform:dpkg]
python3-devel [platform:fedora platform:suse]
# python3-devel does not pull in the python3 package on openSUSE so
# we need to be explicit. The python3 package contains the XML module
# which is required by a python3 virtualenv. Similarly, in python2,
# the XML module is located in python-xml which is not pulled in
# by python-devel as well. See https://bugzilla.suse.com/show_bug.cgi?id=1046990
python3 [platform:suse]
python-xml [platform:suse]
rrdtool-devel [platform:rpm]
sqlite [platform:redhat]
sqlite-devel [platform:redhat]
sqlite3-devel [platform:suse]
sqlite3 [platform:dpkg]
dev-db/sqlite [platform:gentoo]
swig
unzip
uuid-dev [platform:dpkg]
xsltproc [platform:dpkg]
zip
zlib-devel [platform:rpm]
zlib1g-dev [platform:dpkg]
sys-libs/zlib [platform:gentoo]