Browse Source

Expect python3-redis in CentOS8 and Fedora

... because these use python3 instead of python2.

Change-Id: Iee4deab3b1e71cd2cf2f2efea061db545e9ee47c
changes/43/716443/1
Takashi Kajinami 2 years ago
parent
commit
ba65e562b9
  1. 18
      spec/classes/aodh_evaluator_spec.rb

18
spec/classes/aodh_evaluator_spec.rb

@ -118,9 +118,21 @@ describe 'aodh::evaluator' do
:evaluator_service_name => 'aodh-evaluator',
:redis_package_name => 'python3-redis' }
when 'RedHat'
{ :evaluator_package_name => 'openstack-aodh-evaluator',
:evaluator_service_name => 'openstack-aodh-evaluator',
:redis_package_name => 'python-redis' }
if facts[:operatingsystem] == 'Fedora'
{ :evaluator_package_name => 'openstack-aodh-evaluator',
:evaluator_service_name => 'openstack-aodh-evaluator',
:redis_package_name => 'python3-redis' }
else
if facts[:operatingsystemmajrelease] > '7'
{ :evaluator_package_name => 'openstack-aodh-evaluator',
:evaluator_service_name => 'openstack-aodh-evaluator',
:redis_package_name => 'python3-redis' }
else
{ :evaluator_package_name => 'openstack-aodh-evaluator',
:evaluator_service_name => 'openstack-aodh-evaluator',
:redis_package_name => 'python-redis' }
end
end
end
end
it_configures 'aodh-evaluator'

Loading…
Cancel
Save