Browse Source

Expect python3 client package in CentOS8

In CentOS, we expect to have python3 client package in 8.x while we
expect to have python2 in 7.x .
Fix unit tests to expect the correct version according to os major
version.

Change-Id: Ifdc8e09197f15720d585598b54ba9427f436dc3a
changes/09/715909/6
Takashi Kajinami 2 years ago
parent
commit
c8d9f3d508
  1. 6
      spec/classes/aodh_client_spec.rb

6
spec/classes/aodh_client_spec.rb

@ -31,7 +31,11 @@ describe 'aodh::client' do
when 'Debian'
{ :client_package_name => 'python3-aodhclient' }
when 'RedHat'
{ :client_package_name => 'python-aodhclient' }
if facts[:operatingsystemmajrelease] > '7'
{ :client_package_name => 'python3-aodhclient' }
else
{ :client_package_name => 'python-aodhclient' }
end
end
end

Loading…
Cancel
Save