Browse Source

Add missing 'openstack' tag to python3-ceph package

Packages managed by Puppet OpenStack modules should have 'openstack'
tag. This change fixes one package resource without that tag.

Also, this change replaces ensure_resource by ensure_packages, so that
more specific function for package resource is used.

Change-Id: I281c7f4504f7205e7f23458364288179da89d445
changes/41/824841/4
Takashi Kajinami 4 months ago
parent
commit
3162065b1d
  1. 6
      manifests/backend/multistore/rbd.pp
  2. 2
      spec/classes/glance_backend_rbd_spec.rb
  3. 6
      spec/defines/glance_backend_multistore_rbd_spec.rb

6
manifests/backend/multistore/rbd.pp

@ -81,11 +81,11 @@ define glance::backend::multistore::rbd(
"${name}/store_description": value => $store_description;
}
if $manage_packages and !defined(Package["${::glance::params::pyceph_package_name}"]) {
ensure_resource('package', 'python-ceph', {
if $manage_packages and !defined(Package[$::glance::params::pyceph_package_name]) {
ensure_packages('python-ceph', {
ensure => $package_ensure,
name => $::glance::params::pyceph_package_name,
tag => 'glance-support-package',
tag => ['openstack', 'glance-support-package'],
})
}
}

2
spec/classes/glance_backend_rbd_spec.rb

@ -13,7 +13,7 @@ describe 'glance::backend::rbd' do
it { should contain_package('python-ceph').with(
:name => platform_params[:pyceph_package_name],
:ensure => 'present'
:ensure => 'installed'
)}
end

6
spec/defines/glance_backend_multistore_rbd_spec.rb

@ -33,7 +33,8 @@ describe 'glance::backend::multistore::rbd' do
it { should contain_package('python-ceph').with(
:name => platform_params[:pyceph_package_name],
:ensure => 'present'
:ensure => 'installed',
:tag => ['openstack', 'glance-support-package']
)}
end
@ -57,7 +58,8 @@ describe 'glance::backend::multistore::rbd' do
it { should contain_package('python-ceph').with(
:name => platform_params[:pyceph_package_name],
:ensure => 'latest'
:ensure => 'latest',
:tag => ['openstack', 'glance-support-package']
)}
end

Loading…
Cancel
Save