Browse Source

Merge "Prepare 6.0.0 release"

tags/6.0.0^0
Jenkins Gerrit Code Review 4 years ago
parent
commit
7c03b0b80a
3 changed files with 33 additions and 5 deletions
  1. +28
    -0
      CHANGELOG.md
  2. +1
    -1
      README.md
  3. +4
    -4
      metadata.json

+ 28
- 0
CHANGELOG.md View File

@@ -1,3 +1,31 @@
##2015-07-08 - 6.0.0
###Summary

This is a backwards-incompatible major release for OpenStack Kilo.

####Backwards-incompatible changes
- Move rabbit/kombu settings to oslo_messaging_rabbit section
- Remove sql_connection and sql_idle_timeout deprecated parameters
- api: change default pipeline
- Separate api and registry packages for Red Hat
- python-ceph no longer exists in el7, use python-rbd

####Features
- Puppet 4.x support
- Refactorise Keystone resources management
- Migrate postgresql backend to use openstacklib::db::postgresql
- Add support for identity_uri
- Service Validation for Glance-API
- Create a sync_db boolean for Glance
- make service description configurable

####Bugfixes
- Fix API/Registry ensure for Ubuntu

####Maintenance
- Acceptance tests with Beaker
- Fix spec tests for RSpec 3.x and Puppet 4.x

##2015-06-17 - 5.1.0
###Summary



+ 1
- 1
README.md View File

@@ -1,7 +1,7 @@
glance
=======

5.1.0 - 2014.2 - Juno
6.0.0 - 2015.1 - Kilo

#### Table of Contents



+ 4
- 4
metadata.json View File

@@ -1,6 +1,6 @@
{
"name": "stackforge-glance",
"version": "5.1.0",
"name": "openstack-glance",
"version": "6.0.0",
"author": "Puppet Labs and OpenStack Contributors",
"summary": "Puppet module for OpenStack Glance",
"license": "Apache-2.0",
@@ -32,8 +32,8 @@
"description": "Installs and configures OpenStack Glance (Image Service).",
"dependencies": [
{ "name": "puppetlabs/inifile", "version_requirement": ">=1.0.0 <2.0.0" },
{ "name": "stackforge/keystone", "version_requirement": ">=5.0.0 <6.0.0" },
{ "name": "openstack/keystone", "version_requirement": ">=6.0.0 <7.0.0" },
{ "name": "puppetlabs/stdlib", "version_requirement": ">=4.0.0 <5.0.0" },
{ "name": "stackforge/openstacklib", "version_requirement": ">=5.0.0 <6.0.0" }
{ "name": "openstack/openstacklib", "version_requirement": ">=6.0.0 <7.0.0" }
]
}

Loading…
Cancel
Save