Browse Source

Drop compatibility for el6

... because it's now really old, and we don't expect any users
use it to run OpenStack.

Change-Id: Ic13ad21831e937a981cd176e11f733bec9920289
changes/55/716455/6
Takashi Kajinami 2 years ago
parent
commit
e6d89a6355
  1. 6
      manifests/params.pp
  2. 4
      releasenotes/notes/drop-el6-support-c3c167935a8e9b96.yaml

6
manifests/params.pp

@ -16,11 +16,7 @@ class glance::params {
$registry_package_name = 'openstack-glance'
$api_service_name = 'openstack-glance-api'
$registry_service_name = 'openstack-glance-registry'
if ($::operatingsystem != 'fedora' and versioncmp($::operatingsystemrelease, '7') < 0) {
$pyceph_package_name = 'python-ceph'
} else {
$pyceph_package_name = "python${pyvers}-rbd"
}
$pyceph_package_name = "python${pyvers}-rbd"
}
'Debian': {
$api_package_name = 'glance-api'

4
releasenotes/notes/drop-el6-support-c3c167935a8e9b96.yaml

@ -0,0 +1,4 @@
---
upgrade:
- |
Support for el6 (RHEL6.x, CentOS6.x and so on) has been removed.
Loading…
Cancel
Save