OpenStack Glare Puppet Module
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

metadata.json 1.5KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. {
  2. "name": "openstack-glare",
  3. "version": "4.0.0",
  4. "author": "OpenStack Contributors",
  5. "summary": "Puppet module for OpenStack Glare",
  6. "license": "Apache-2.0",
  7. "source": "git://github.com/openstack/puppet-glare.git",
  8. "project_page": "https://launchpad.net/puppet-glare",
  9. "issues_url": "https://bugs.launchpad.net/puppet-glare",
  10. "description": "Installs and configures OpenStack Glare.",
  11. "requirements": [
  12. {
  13. "name": "puppet",
  14. "version_requirement": "5.x"
  15. }
  16. ],
  17. "operatingsystem_support": [
  18. {
  19. "operatingsystem": "RedHat",
  20. "operatingsystemrelease": [
  21. "7"
  22. ]
  23. },
  24. {
  25. "operatingsystem": "Ubuntu",
  26. "operatingsystemrelease": [
  27. "18.04"
  28. ]
  29. }
  30. ],
  31. "dependencies": [
  32. {
  33. "name": "puppetlabs/inifile",
  34. "version_requirement": ">=2.0.0 <3.0.0"
  35. },
  36. {
  37. "name": "puppetlabs/stdlib",
  38. "version_requirement": ">= 5.0.0 <6.0.0"
  39. },
  40. {
  41. "name": "puppetlabs/mysql",
  42. "version_requirement": ">=6.0.0 <9.0.0"
  43. },
  44. {
  45. "name": "openstack/openstacklib",
  46. "version_requirement": ">=15.0.0 <16.0.0"
  47. },
  48. {
  49. "name": "openstack/keystone",
  50. "version_requirement": ">=15.0.0 <16.0.0"
  51. },
  52. {
  53. "name": "openstack/oslo",
  54. "version_requirement": ">=15.0.0 <16.0.0"
  55. }
  56. ]
  57. }