Browse Source

Use puppet 4 compatible mysql functions

These was introduced in 6.0.0 and is required to
support later version of puppetlabs-mysql.

Change-Id: I7244add57cf29c851ecd3cf49b3be721a13549d9
tags/14.3.0
Tobias Urdin 3 months ago
parent
commit
be384424e4

+ 1
- 1
manifests/db/mysql.pp View File

@@ -49,7 +49,7 @@ class heat::db::mysql(
49 49
 
50 50
   ::openstacklib::db::mysql { 'heat':
51 51
     user          => $user,
52
-    password_hash => mysql_password($password),
52
+    password_hash => mysql::password($password),
53 53
     dbname        => $dbname,
54 54
     host          => $host,
55 55
     charset       => $charset,

+ 4
- 0
metadata.json View File

@@ -13,6 +13,10 @@
13 13
             "name": "puppetlabs/rabbitmq",
14 14
             "version_requirement": ">=8.4.0 <9.0.0"
15 15
         },
16
+        {
17
+            "name": "puppetlabs/mysql",
18
+            "version_requirement": ">=6.0.0 <9.0.0"
19
+        },
16 20
         {
17 21
             "name": "puppetlabs/stdlib",
18 22
             "version_requirement": ">=5.0.0 <6.0.0"

+ 4
- 0
releasenotes/notes/puppet4-mysql-func-9583edec939bbaa2.yaml View File

@@ -0,0 +1,4 @@
1
+---
2
+upgrade:
3
+  - |
4
+    This module now requires a puppetlabs-mysql version >= 6.0.0

Loading…
Cancel
Save