puppet-ironic/metadata.json

74 lines
2.0 KiB
JSON

{
"author": "eNovance and OpenStack Contributors",
"dependencies": [
{
"name": "puppetlabs/inifile",
"version_requirement": ">=2.0.0 <7.0.0"
},
{
"name": "openstack/keystone",
"version_requirement": ">=24.0.0 <25.0.0"
},
{
"name": "puppetlabs/stdlib",
"version_requirement": ">=5.0.0 <10.0.0"
},
{
"name": "openstack/openstacklib",
"version_requirement": ">=24.0.0 <25.0.0"
},
{
"name": "openstack/oslo",
"version_requirement": ">=24.0.0 <25.0.0"
},
{
"name": "puppetlabs/apache",
"version_requirement": ">=5.0.0 <13.0.0"
},
{
"name": "puppetlabs/xinetd",
"version_requirement": ">=1.5.0 <=4.0.0"
}
],
"description": "Installs and configures OpenStack Ironic (Bare metal).",
"issues_url": "https://bugs.launchpad.net/puppet-ironic",
"license": "Apache-2.0",
"name": "openstack-ironic",
"operatingsystem_support": [
{
"operatingsystem": "Debian",
"operatingsystemrelease": [
"12"
]
},
{
"operatingsystem": "RedHat",
"operatingsystemrelease": [
"9"
]
},
{
"operatingsystem": "CentOS",
"operatingsystemrelease": [
"9"
]
},
{
"operatingsystem": "Ubuntu",
"operatingsystemrelease": [
"22.04"
]
}
],
"project_page": "https://launchpad.net/puppet-ironic",
"requirements": [
{
"name": "puppet",
"version_requirement": ">= 7.0.0 < 8.0.0"
}
],
"source": "https://opendev.org/openstack/puppet-ironic.git",
"summary": "Puppet module for OpenStack Ironic",
"version": "24.0.0"
}