Browse Source

Remove usage of custom os_package_type fact

Currently we support usage of distro packages only, and this custom
fact can be simply replaced by the default fact.

Change-Id: I7b95079b1ec59da3b4b9d1cd149019acaa80ea7b
changes/16/823516/2
Takashi Kajinami 6 months ago
parent
commit
c32b1e1e74
  1. 2
      manifests/init.pp
  2. 2
      manifests/wsgi/uwsgi.pp

2
manifests/init.pp

@ -695,7 +695,7 @@ removed in a future realse. Use keystone::db::database_max_overflow instead')
# Note: Debian uses uwsgi if using keystone service, which isn't deprecated
# and therefore, no warning should be displayed.
if $service_name == $::keystone::params::service_name and $::os_package_type != 'debian'{
if $service_name == $::keystone::params::service_name and $::operatingsystem != 'Debian'{
warning("Keystone under Eventlet has been deprecated during the Kilo cycle. \
Support for deploying under eventlet will be dropped as of the M-release of OpenStack.")
}

2
manifests/wsgi/uwsgi.pp

@ -29,7 +29,7 @@ class keystone::wsgi::uwsgi (
include keystone::deps
if $::os_package_type != 'debian'{
if $::operatingsystem != 'Debian'{
warning('This class is only valid for Debian, as other operating systems are not using uwsgi by default.')
}

Loading…
Cancel
Save