Browse Source

Merge "Revert "Deprecate support for networking-mlnx""

changes/93/802293/2 19.1.0
Zuul 2 months ago
committed by Gerrit Code Review
parent
commit
18dface2c9
  1. 2
      manifests/agents/ml2/mlnx.pp
  2. 4
      manifests/plugins/ml2/mellanox.pp
  3. 4
      manifests/plugins/ml2/mellanox/mlnx_sdn_assist.pp
  4. 5
      releasenotes/notes/deprecate-networking-mlnx-1585b2f692e2cfe5.yaml

2
manifests/agents/ml2/mlnx.pp

@ -1,7 +1,6 @@
#
# == Class: neutron::agents::ml2::mlnx
#
# DEPRECATED !
# Setups MLNX neutron agent when using ML2 plugin
#
# === Parameters
@ -74,7 +73,6 @@ class neutron::agents::ml2::mlnx (
$ipoib_physical_interface = $::os_service_default,
$enable_multi_interface_driver_cache_maintenance = false,
) {
warning('Support for networking-mlnx has been deprecated')
include neutron::deps
include neutron::params

4
manifests/plugins/ml2/mellanox.pp

@ -1,7 +1,4 @@
#
# == Class: neutron::plugins::ml2::mellanox
#
# DEPRECATED !
# Install the Mellanox plugins and generate the config file
# from parameters in the other classes.
#
@ -17,7 +14,6 @@
class neutron::plugins::ml2::mellanox (
$package_ensure = 'present'
) {
warning('Support for networking-mlnx has been deprecated')
include neutron::deps
include neutron::params

4
manifests/plugins/ml2/mellanox/mlnx_sdn_assist.pp

@ -1,7 +1,4 @@
#
# == Class: neutron::plugins::ml2::mellanox::mlnx_sdn_assist
#
# DEPRECATED !
# Install the OpenDaylight and generate config file
# from parameters in the other classes.
#
@ -53,7 +50,6 @@ class neutron::plugins::ml2::mellanox::mlnx_sdn_assist (
$bind_normal_ports = false,
$bind_normal_ports_physnets = [],
) {
warning('Support for networking-mlnx has been deprecated')
include neutron::deps
require neutron::plugins::ml2

5
releasenotes/notes/deprecate-networking-mlnx-1585b2f692e2cfe5.yaml

@ -1,5 +0,0 @@
---
deprecations:
- |
Support for networking-mlnx has been deprecated and will be removed in
a future release.
Loading…
Cancel
Save