Browse Source

Remove compatibility codes for CentOS<=6

... because CentOS6 is no longer supported.

Change-Id: I0e48743407a458a3e530fca59ba20a28fe60cb66
changes/03/733603/3
Takashi Kajinami 1 year ago
parent
commit
bf3ed618b4
  1. 11
      manifests/params.pp

11
manifests/params.pp

@ -52,16 +52,11 @@ class nova::params {
$nova_api_wsgi_script_source = '/usr/bin/nova-api-wsgi'
$nova_metadata_wsgi_script_source = '/usr/bin/nova-metadata-wsgi'
case $::operatingsystem {
'RedHat', 'CentOS', 'Scientific', 'OracleLinux': {
if (versioncmp($::operatingsystemmajrelease, '7') < 0) {
$messagebus_service_name = 'messagebus'
} else {
$messagebus_service_name = 'dbus'
}
'Fedora': {
$messagebus_service_name = undef
}
default: {
# not required on Fedora
$messagebus_service_name = undef
$messagebus_service_name = 'dbus'
}
}
$nova_user = 'nova'

Loading…
Cancel
Save