Clean r10k installation

In the past we had to workaround some issues related to r10k
installation and dependencies. However, apparently some of those issues
have been fixed and we don't need to pin to specific gem versions
anymore.

Change-Id: I16436d23a7853afe029920b3ea2f61058c133010
changes/29/792129/1
Alfredo Moralejo 2 years ago
parent c368e402d1
commit acdcae90f7

@ -25,14 +25,7 @@ source $SCRIPT_DIR/functions
print_header 'Start (install_modules.sh)'
print_header 'Install r10k'
# fast_gettext 1.2.0+ requires ruby 2.1.0
$GEM_INSTALL_CMD fast_gettext -v '< 1.2.0'
# gettext 3.3.0+ requires ruby 2.5.0
$GEM_INSTALL_CMD gettext -v '< 3.3.0'
# puppet_forge 2.2.7 has a dependency on semantic_puppet ~> 1.0
# which is not compatible with dependency of latest r10k on semantic_puppet ~> 0.1.0
$GEM_INSTALL_CMD puppet_forge -v '= 2.2.6'
$GEM_INSTALL_CMD r10k -v 2.6.4
$GEM_INSTALL_CMD r10k
# make sure there is no puppet module pre-installed
rm -rf "${PUPPETFILE_DIR:?}/"*

Loading…
Cancel
Save