Browse Source

Switch from oslosphinx to openstackdocstheme

As part of the docs migration work[0] for Pike we need to switch to use the
openstackdocstheme.

[0]https://review.openstack.org/#/c/472275/

Change-Id: I810f268def6cc0f831ed1795632f8c3453e9813d
changes/91/477291/2
ZhongShengping 4 years ago
parent
commit
de67a39d4f
  1. 7
      releasenotes/source/conf.py
  2. 2
      test-requirements.txt

7
releasenotes/source/conf.py

@ -19,6 +19,8 @@
# -- General configuration ------------------------------------------------
import openstackdocstheme
# If your documentation needs a minimal Sphinx version, state it here.
#needs_sphinx = '1.0'
@ -26,7 +28,6 @@
# extensions coming with Sphinx (named 'sphinx.ext.*') or your custom
# ones.
extensions = [
'oslosphinx',
'reno.sphinxext',
]
@ -98,7 +99,7 @@ pygments_style = 'sphinx'
# The theme to use for HTML and HTML Help pages. See the documentation for
# a list of builtin themes.
html_theme = 'default'
html_theme = 'openstackdocs'
# Theme options are theme-specific and customize the look and feel of a theme
# further. For a list of options available for each theme, see the
@ -106,7 +107,7 @@ html_theme = 'default'
#html_theme_options = {}
# Add any paths that contain custom themes here, relative to this directory.
#html_theme_path = []
html_theme_path = [openstackdocstheme.get_html_theme_path()]
# The name for this set of Sphinx documents. If None, it defaults to
# "<project> v<release> documentation".

2
test-requirements.txt

@ -1,6 +1,6 @@
# This is required for the docs build jobs
sphinx!=1.6.1,>=1.5.1 # BSD
oslosphinx>=4.7.0 # Apache-2.0
openstackdocstheme>=1.5.0 # Apache-2.0
# This is required for the releasenotes build jobs
# FIXME: reno is manually pinned to !=2.0.0 because of bug #1651995

Loading…
Cancel
Save