Library gem used by Puppet OpenStack modules
Go to file
OpenStack Release Bot 691aa7528d reno: Update master for unmaintained/zed
Update the zed release notes configuration to build from
unmaintained/zed.

Change-Id: If6bb76e1415ade12dfbae668b98dcab6d8b52401
2024-05-10 09:22:56 +00:00
doc Update openstackdocstheme to the latest version 2021-09-29 16:06:50 +08:00
lib/puppet-openstack_spec_helper Debian: Switch to Debian 12 (Bookworm) 2023-11-09 03:44:55 +00:00
releasenotes reno: Update master for unmaintained/zed 2024-05-10 09:22:56 +00:00
.gitignore Dissuade .gitignore references to personal tools 2018-10-08 11:47:07 +08:00
.gitreview OpenDev Migration Patch 2019-04-19 19:32:19 +00:00
.zuul.yaml Re-enable puppet jobs 2023-01-24 10:53:29 +09:00
bindep.txt Move other-requirements.txt to bindep.txt 2016-08-12 21:10:46 +02:00
CHANGELOG.md Release 8.0.0 2016-03-21 15:20:20 -04:00
functions Merge "Drop unnecessary modification of Gemfile" 2023-12-21 17:14:44 +00:00
LICENSE Update LICENSE 2018-04-06 20:14:56 +08:00
puppet-openstack_spec_helper.gemspec Merge "Bump default puppet version from 6 to 7" 2023-05-22 14:56:40 +00:00
README.md Remove beaker 2020-09-20 17:46:24 +00:00
run_lint_tests.sh Add run_lint_tests.sh 2016-06-23 17:05:05 -04:00
run_litmus_tests.sh Change to Litmus 2020-09-19 00:40:12 +02:00
run_syntax_tests.sh Bump default puppet version from 6 to 7 2023-05-22 13:24:02 +09:00
run_unit_tests.sh Support puppet 4.8 and latest for libraries unit test 2018-03-27 16:00:22 +08:00
setup.cfg Add information technology in the setup.cfg 2021-10-01 06:54:49 +08:00
setup.py setuptools: Disable auto discovery 2022-03-29 10:41:08 +02:00
tox.ini Replace deprecated UPPER_CONSTRAINTS_FILE variable 2020-11-11 09:08:35 +08:00

Team and repository tags

Team and repository tags

Puppet-OpenStack Spec Helper

This gem provides helper utilities for running rspec tests in the OpenStack Puppet Modules.

Usage

Include this gem in your Gemfile:

gem 'puppet-openstack_spec_helper',
  :git => 'https://opendev.org/openstack/puppet-openstack_spec_helper',
  :require => false

In your Rakefile, require the rake_tasks library:

require 'puppet-openstack_spec_helper/rake_tasks'

Release notes for the project can be found at: https://docs.openstack.org/releasenotes/puppet-openstack_spec_helper

The project source code repository is located at: https://opendev.org/openstack/puppet-openstack_spec_helper

Contributors for the project can be found at: https://github.com/openstack/puppet-openstack_spec_helper/graphs/contributors

Developer documentation for the entire puppet-openstack project can be found at: https://docs.openstack.org/puppet-openstack-guide/latest/