Browse Source

Remove obsolete 'http' backend from glance configuration

Glance has a read-only 'http' backend that is obsolete now that tripleo
supports glance multi-store (multiple backends). Glance's web-download
import method no longer relies on the 'http' backend, so tripleo should
no longer include 'http' in the list of enabled backends.

Change-Id: I64ee3a3c8f0dabdeab16968c39ea00b8879f5405
(cherry picked from commit a2a04ed488)
(cherry picked from commit b1b435e95d)
changes/73/733973/1
Alan Bishop 1 month ago
parent
commit
68291df8ac
2 changed files with 2 additions and 3 deletions
  1. +1
    -1
      manifests/profile/base/glance/api.pp
  2. +1
    -2
      spec/classes/tripleo_profile_base_glance_api_spec.rb

+ 1
- 1
manifests/profile/base/glance/api.pp View File

@@ -196,7 +196,7 @@ class tripleo::profile::base::glance::api (
"${backend_config[0]}:${backend_config[1]['GlanceBackend']}"
}

$enabled_backends = ["${glance_backend_id}:${glance_backend}", 'http:http'] + $multistore_backends
$enabled_backends = ["${glance_backend_id}:${glance_backend}"] + $multistore_backends

include ::glance
include ::glance::config


+ 1
- 2
spec/classes/tripleo_profile_base_glance_api_spec.rb View File

@@ -101,7 +101,7 @@ describe 'tripleo::profile::base::glance::api' do
is_expected.to contain_class('glance::config')
is_expected.to contain_class('glance::api::logging')
is_expected.to contain_class('glance::api').with(
:enabled_backends => ['default_backend:swift', 'http:http'],
:enabled_backends => ['default_backend:swift'],
:default_backend => 'default_backend',
)
is_expected.to_not contain_class('tripleo::profile::base::glance::backend::cinder')
@@ -147,7 +147,6 @@ describe 'tripleo::profile::base::glance::api' do
is_expected.to contain_class('glance::api').with(
:enabled_backends => [
'my_cinder:cinder',
'http:http',
'my_file:file',
'rbd1:rbd',
'rbd2:rbd',


Loading…
Cancel
Save