Browse Source

Drop Fedora support

Fedora support is never tested, and has been unmaintained for a while.
Because we don't expect any actual user using OpenStack on Fedora, this
change drops support for Fedora directly.

Change-Id: Ia6de5e2c389edaecd560f1f13a19fcf17b9f6bb5
changes/03/796103/4
zhangboye 4 months ago
committed by Takashi Kajinami
parent
commit
db032d6829
  1. 6
      metadata.json
  2. 4
      releasenotes/notes/drop-fedora-56709758aa310b8d.yaml
  3. 22
      spec/classes/watcher_wsgi_apache_spec.rb

6
metadata.json

@ -33,12 +33,6 @@
"9"
]
},
{
"operatingsystem": "Fedora",
"operatingsystemrelease": [
"24"
]
},
{
"operatingsystem": "RedHat",
"operatingsystemrelease": [

4
releasenotes/notes/drop-fedora-56709758aa310b8d.yaml

@ -0,0 +1,4 @@
---
upgrade:
- |
Fedora is no longer supported.

22
spec/classes/watcher_wsgi_apache_spec.rb

@ -95,24 +95,10 @@ describe 'watcher::wsgi::apache' do
:wsgi_script_source => '/usr/lib/python3/dist-packages/watcher/api/app.wsgi'
}
when 'RedHat'
if facts[:operatingsystem] == 'Fedora'
{
:wsgi_script_path => '/var/www/cgi-bin/watcher',
:wsgi_script_source => '/usr/lib/python3.6/site-packages/watcher/api/app.wsgi'
}
else
if facts[:operatingsystemmajrelease] > '7'
{
:wsgi_script_path => '/var/www/cgi-bin/watcher',
:wsgi_script_source => '/usr/lib/python3.6/site-packages/watcher/api/app.wsgi'
}
else
{
:wsgi_script_path => '/var/www/cgi-bin/watcher',
:wsgi_script_source => '/usr/lib/python2.7/site-packages/watcher/api/app.wsgi'
}
end
end
{
:wsgi_script_path => '/var/www/cgi-bin/watcher',
:wsgi_script_source => '/usr/lib/python3.6/site-packages/watcher/api/app.wsgi'
}
end
end

Loading…
Cancel
Save