Browse Source

Cleanup py27 support

Make a few cleanups:
- Remove python 2.7 stanza from setup.py
- Add requires on python >= 3.6 to setup.cfg so that pypi and pip
  know about the requirement
- Remove obsolete sections from setup.cfg
- Update classifiers
- Update requirements, no need for python_version anymore

Change-Id: I28b14bfc8430d75271308ee91925e58b55b6dcc2
changes/58/717458/1 ussuri-em
Andreas Jaeger 2 years ago
parent
commit
e7685d5df6
  1. 2
      doc/requirements.txt
  2. 8
      setup.cfg
  3. 9
      setup.py

2
doc/requirements.txt

@ -4,4 +4,4 @@
openstackdocstheme>=1.18.1 # Apache-2.0
reno>=2.5.0 # Apache-2.0
sphinx>=1.8.0,!=2.1.0;python_version>='3.4' # BSD
sphinx>=1.8.0,!=2.1.0 # BSD

8
setup.cfg

@ -3,8 +3,11 @@ name = python-blazarclient
summary = Client for OpenStack Reservation Service
description-file = README.rst
license = Apache Software License
python-requires = >=3.6
classifiers =
Programming Language :: Python
Programming Language :: Python :: Implementation :: CPython
Programming Language :: Python :: 3 :: Only
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
@ -26,8 +29,3 @@ packages =
[entry_points]
console_scripts =
blazar = blazarclient.shell:main
[build_sphinx]
all_files = 1
build-dir = doc/build
source-dir = doc/source

9
setup.py

@ -13,17 +13,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
# In python < 2.7.4, a lazy loading of package `pbr` will break
# setuptools if some other modules registered functions in `atexit`.
# solution from: http://bugs.python.org/issue15881#msg170215
try:
import multiprocessing # noqa
except ImportError:
pass
setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)

Loading…
Cancel
Save