Bump hacking max version to 3.0.1 and fix pep8

pep8 job is failing because the version of flake8
(flake8<2.7.0,>=2.6.0) requested by hacking<1.2.0 is not
compatible with pyflakes>=2.1.1. Therefore the patch increases
the max version of hacking.
Also the patch fixes a few pep8 errors.

Change-Id: Ib9f1cb5a77947cfb1ab28a7f26e97edba007466c
changes/63/769063/2
Martin Kopec 2 years ago
parent 56c539ace9
commit e875b75392
  1. 2
      blazarclient/utils.py
  2. 2
      test-requirements.txt
  3. 3
      tox.ini

@ -22,7 +22,7 @@ from oslo_serialization import jsonutils as json
from blazarclient import exception
from blazarclient.i18n import _
ELAPSED_TIME_REGEX = '^(\d+)([s|m|h|d])$'
ELAPSED_TIME_REGEX = '^(\d+)([s|m|h|d])$' # noqa W605
LEASE_DATE_FORMAT = '%Y-%m-%dT%H:%M:%S.%f'
API_DATE_FORMAT = '%Y-%m-%d %H:%M'

@ -1,7 +1,7 @@
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
hacking>=1.1.0,<1.2.0 # Apache-2.0
hacking>=1.1.0,<3.0.1 # Apache-2.0
# remove this pyflakes from here once you bump the
# hacking to 3.2.0 or above. hacking 3.2.0 takes
# care of pyflakes version compatibilty.

@ -22,7 +22,8 @@ commands = flake8
show-source = true
builtins = _
# Ignore currently failing tests for now
ignore = E265,H405
# W504 skipped because it is overeager and unnecessary
ignore = E265,H405,W504
exclude=.venv,.git,.tox,dist,doc,*lib/python*,*egg
[hacking]

Loading…
Cancel
Save