Browse Source

[goal] Migrate testing to ubuntu focal

As per victoria cycle testing runtime and community goal[1]
we need to migrate upstream CI/CD to Ubuntu Focal(20.04).

Fixing:
- bug#1886298
Bump the lower constraints for required deps which added python3.8
support in their later version.

- noqa for pep8 C901 check.

Closes-Bug: #1886298

Story: #2007865
Task: #40186

[1] https://governance.openstack.org/tc/goals/selected/victoria/migrate-ci-cd-jobs-to-ubuntu-focal

Change-Id: I67b4957cea1ccbd5cdc0314d2eaddef0c24f7dfc
changes/80/750080/3
Ghanshyam Mann 11 months ago
parent
commit
17958681f6
  1. 2
      heatclient/v1/shell.py
  2. 8
      lower-constraints.txt
  3. 4
      requirements.txt

2
heatclient/v1/shell.py

@ -740,7 +740,7 @@ def do_output_list(hc, args):
@utils.arg('--with-detail', default=False, action="store_true",
help=_('Enable detail information presented, like '
'key and description.'))
def do_output_show(hc, args):
def do_output_show(hc, args): # noqa: C901
"""Show a specific stack output."""
show_deprecated('heat output-show', 'openstack stack output show')

8
lower-constraints.txt

@ -2,11 +2,11 @@ alabaster==0.7.10
appdirs==1.3.0
asn1crypto==0.23.0
Babel==2.3.4
cffi==1.7.0
cffi==1.14.0
cliff==2.8.0
cmd2==0.8.0
coverage==4.0
cryptography==2.1
cryptography==2.7
debtcollector==1.2.0
decorator==3.4.0
deprecation==1.0
@ -40,7 +40,7 @@ openstacksdk==0.11.2
os-client-config==1.28.0
os-service-types==1.2.0
os-testr==1.0.0
osc-lib==1.8.0
osc-lib==1.14.0
oslo.concurrency==3.25.0
oslo.config==5.2.0
oslo.context==2.19.2
@ -71,7 +71,7 @@ python-openstackclient==3.12.0
python-subunit==1.0.0
python-swiftclient==3.2.0
pytz==2013.6
PyYAML==3.12
PyYAML==3.13
requests-mock==1.2.0
requests==2.14.2
requestsexceptions==1.2.0

4
requirements.txt

@ -6,13 +6,13 @@ Babel!=2.4.0,>=2.3.4 # BSD
pbr!=2.1.0,>=2.0.0 # Apache-2.0
cliff!=2.9.0,>=2.8.0 # Apache-2.0
iso8601>=0.1.11 # MIT
osc-lib>=1.8.0 # Apache-2.0
osc-lib>=1.14.0 # Apache-2.0
PrettyTable<0.8,>=0.7.2 # BSD
oslo.i18n>=3.15.3 # Apache-2.0
oslo.serialization!=2.19.1,>=2.18.0 # Apache-2.0
oslo.utils>=3.33.0 # Apache-2.0
keystoneauth1>=3.4.0 # Apache-2.0
python-swiftclient>=3.2.0 # Apache-2.0
PyYAML>=3.12 # MIT
PyYAML>=3.13 # MIT
requests>=2.14.2 # Apache-2.0
six>=1.10.0 # MIT
Loading…
Cancel
Save