Browse Source

Dep's should be restricted by tox-constraints

Tox trying to install latest versions for building docs which may
not be supported by stable and lower branches, so should be
restricted by respective version's tox-constraints.txt

Change-Id: Iecd29788d1c94fd727072aa5dd7fe5d828dbf174
changes/04/763504/1
wu.shiming 8 months ago
parent
commit
1a1ee061e8
  1. 8
      tox.ini

8
tox.ini

@ -51,7 +51,9 @@ commands =
coverage report
[testenv:docs]
deps = -r{toxinidir}/doc/requirements.txt
deps =
-c{env:TOX_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/master}
-r{toxinidir}/doc/requirements.txt
commands = sphinx-build -W -b html doc/source doc/build/html
[testenv:pdf-docs]
@ -64,7 +66,9 @@ commands =
make -C doc/build/pdf
[testenv:releasenotes]
deps = -r{toxinidir}/doc/requirements.txt
deps =
-c{env:TOX_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/master}
-r{toxinidir}/doc/requirements.txt
commands = sphinx-build -a -E -d releasenotes/build/doctrees -b html releasenotes/source releasenotes/build/html
[flake8]

Loading…
Cancel
Save