Browse Source

Bump hacking to 0.9.x series

In order to keep this patch to just a requirements bump, ignore new and
stricter hacking rules that are being triggered. Fixing up the code and
turning these on is out of scope of this patch and is for future
patches.

Change-Id: Ia3517e705f894b48585b957c21e7a3a6ed90e586
tags/2.18.0
Joe Gordon 5 years ago
parent
commit
9f92301983
2 changed files with 4 additions and 2 deletions
  1. 1
    1
      test-requirements.txt
  2. 3
    1
      tox.ini

+ 1
- 1
test-requirements.txt View File

@@ -1,4 +1,4 @@
1
-hacking>=0.8.0,<0.9
1
+hacking>=0.9.2,<0.10
2 2
 
3 3
 coverage>=3.6
4 4
 discover

+ 3
- 1
tox.ini View File

@@ -25,6 +25,8 @@ commands = python setup.py testr --coverage --testr-args='{posargs}'
25 25
 downloadcache = ~/cache/pip
26 26
 
27 27
 [flake8]
28
-ignore = E12,F841,F811,F821,H302,H404
28
+# TODO fix following rules from hacking 0.9
29
+# E131,E265,H233,H305,H307,H402,H405,H904
30
+ignore = E12,E131,E265,F841,F811,F821,H233,H302,H305,H307,H402,H404,H405,H904
29 31
 show-source = True
30 32
 exclude=.venv,.git,.tox,dist,*openstack/common*,*lib/python*,*egg,build

Loading…
Cancel
Save