Browse Source

Fix the lower-constraints job for focal

The move to focal for the tox jobs has raised issues with package
versions supporting python 3.8.
This patch bumps the version for the following packages:
cffi==1.14.0
cryptography==3.0
pyOpenSSL==19.1.0

Change-Id: I72c7bdd07a0b571fea01f76d8579a8d84057ebf8
changes/47/751047/2
Michael Johnson 11 months ago
parent
commit
898d0b747b
  1. 8
      lower-constraints.txt
  2. 2
      requirements.txt

8
lower-constraints.txt

@ -1,9 +1,9 @@
asn1crypto==0.23.0
bandit==1.4.0
cffi==1.7.0
cffi==1.14.0
cliff==2.8.0
coverage==4.0
cryptography==2.1
cryptography==3.0
decorator==3.4.0
deprecation==1.0
doc8==0.6.0
@ -23,7 +23,7 @@ munch==2.1.0
netifaces==0.10.4
openstacksdk==0.11.2
os-service-types==1.2.0
osc-lib==1.8.0
osc-lib==1.14.1
oslo.config==5.2.0
oslo.serialization==2.18.0
oslo.utils==3.33.0
@ -33,7 +33,7 @@ positional==1.2.1
pycparser==2.18
Pygments==2.2.0
pylint==1.9.2
pyOpenSSL==17.1.0
pyOpenSSL==19.1.0
pyperclip==1.5.27
python-cinderclient==3.3.0
python-glanceclient==2.8.0

2
requirements.txt

@ -6,7 +6,7 @@ cliff!=2.9.0,>=2.8.0 # Apache-2.0
keystoneauth1>=3.4.0 # Apache-2.0
python-neutronclient>=6.7.0 # Apache-2.0
python-openstackclient>=3.12.0 # Apache-2.0
osc-lib>=1.8.0 # Apache-2.0
osc-lib>=1.14.1 # Apache-2.0
oslo.serialization!=2.19.1,>=2.18.0 # Apache-2.0
oslo.utils>=3.33.0 # Apache-2.0
pbr!=2.1.0,>=2.0.0 # Apache-2.0

Loading…
Cancel
Save