Browse Source

Fix hacking min version to 3.0.1

flake8 new release 3.8.0 added new checks and gate pep8
job start failing. hacking 3.0.1 fix the pinning of flake8 to
avoid bringing in a new version with new checks.

Though it is fixed in latest hacking but 2.0 and 3.0 has cap for
flake8 as <4.0.0 which mean flake8 new version 3.9.0 can also
break the pep8 job if new check are added.

To avoid similar gate break in future, we need to bump the hacking min
version.

Also removing the hacking and other related dep from lower-constraints file
as theose are blacklisted requirements and does not need to be present
there.

- http://lists.openstack.org/pipermail/openstack-discuss/2020-May/014828.html

Change-Id: Iaddbf2b55b3ec29fc8f12a226a97f691143165ad
changes/54/727554/7
Ghanshyam Mann 1 year ago
committed by Michael Johnson
parent
commit
f525c3912e
  1. 5
      lower-constraints.txt
  2. 2
      test-requirements.txt

5
lower-constraints.txt

@ -10,9 +10,6 @@ doc8==0.6.0
dogpile.cache==0.6.2
extras==1.0.0
fixtures==3.0.0
flake8==2.5.5
flake8-import-order==0.12
hacking==1.1.0
idna==2.6
jmespath==0.9.0
jsonpatch==1.16
@ -32,10 +29,8 @@ oslo.serialization==2.18.0
oslo.utils==3.33.0
oslotest==3.2.0
pbr==2.0.0
pep8==1.5.7
positional==1.2.1
pycparser==2.18
pyflakes==0.8.1
Pygments==2.2.0
pylint==1.9.2
pyOpenSSL==17.1.0

2
test-requirements.txt

@ -2,7 +2,7 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
hacking>=3.0,<3.1.0 # Apache-2.0
hacking>=3.0.1,<3.1.0 # Apache-2.0
requests-mock>=1.2.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
doc8>=0.6.0 # Apache-2.0

Loading…
Cancel
Save