Browse Source

default OS_VOLUME_API_VERSION to v2

Cinder is trying to deprecate/remove support for v1, so we should,
as a client library default to v2 and keep support for v1.

Related-Bug: 1467589

Change-Id: I732448a57fc3fd06a8d82ec0f0d2ace671036ca2
tags/1.7.0
Steve Martinelli 4 years ago
parent
commit
f14251669f
1 changed files with 1 additions and 1 deletions
  1. 1
    1
      openstackclient/volume/client.py

+ 1
- 1
openstackclient/volume/client.py View File

@@ -19,7 +19,7 @@ from openstackclient.common import utils
19 19
 
20 20
 LOG = logging.getLogger(__name__)
21 21
 
22
-DEFAULT_API_VERSION = '1'
22
+DEFAULT_API_VERSION = '2'
23 23
 API_VERSION_OPTION = 'os_volume_api_version'
24 24
 API_NAME = "volume"
25 25
 API_VERSIONS = {

Loading…
Cancel
Save