Browse Source

Cleanup py27 support

Make a few cleanups:
- Remove python 2.7 stanza from setup.py
- Add requires on python >= 3.6 to setup.cfg so that pypi and pip
  know about the requirement
- Remove obsolete sections from setup.cfg:
  * Wheel is not needed for python 3 only repo
  * Some other sections are obsolete
- Update classifiers
- Update requirements, no need for python_version anymore

Change-Id: I45b5b8582b67b39823a6e21221c491842b390b96
changes/83/717483/1
Andreas Jaeger 1 year ago
parent
commit
655e0178a1
5 changed files with 5 additions and 20 deletions
  1. +1
    -2
      doc/requirements.txt
  2. +0
    -2
      lower-constraints.txt
  3. +1
    -4
      requirements.txt
  4. +3
    -3
      setup.cfg
  5. +0
    -9
      setup.py

+ 1
- 2
doc/requirements.txt View File

@ -1,8 +1,7 @@
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
sphinx>=1.8.0,<2.0.0;python_version=='2.7' # BSD
sphinx>=1.8.0,!=2.1.0;python_version>='3.4' # BSD
sphinx>=1.8.0,!=2.1.0 # BSD
sphinxcontrib-svg2pdfconverter>=0.1.0 # BSD
openstackdocstheme>=1.30.0 # Apache-2.0
reno>=2.5.0 # Apache-2.0

+ 0
- 2
lower-constraints.txt View File

@ -26,7 +26,6 @@ extras==1.0.0
fasteners==0.7.0
fixtures==3.0.0
flake8==2.5.5
futures==3.0.0
futurist==1.2.0
gitdb==0.6.4
GitPython==1.0.1
@ -35,7 +34,6 @@ greenlet==0.4.10
hacking==0.12.0
httplib2==0.9.1
idna==2.6
ipaddress==1.0.17;python_version<'3.3' # PSF
iso8601==0.1.11
Jinja2==2.10
jmespath==0.9.0


+ 1
- 4
requirements.txt View File

@ -4,13 +4,11 @@
pbr!=2.1.0,>=2.0.0 # Apache-2.0
Babel!=2.4.0,>=2.3.4 # BSD
ipaddress>=1.0.17;python_version<'3.3' # PSF
passlib>=1.7.0 # BSD
psutil>=3.2.2 # BSD
python-ironic-inspector-client>=1.5.0 # Apache-2.0
python-heatclient>=1.10.0 # Apache-2.0
python-ironicclient!=2.5.2,!=2.7.1,!=3.0.0,>=2.3.0,<4.0.0;python_version=='2.7' # Apache-2.0
python-ironicclient!=2.5.2,!=2.7.1,!=3.0.0,>=2.3.0;python_version>='3.6' # Apache-2.0
python-ironicclient!=2.5.2,!=2.7.1,!=3.0.0,>=2.3.0 # Apache-2.0
python-mistralclient!=3.2.0,>=3.1.0 # Apache-2.0
python-openstackclient>=5.2.0 # Apache-2.0
simplejson>=3.5.1 # MIT
@ -19,5 +17,4 @@ osc-lib>=1.8.0 # Apache-2.0
websocket-client>=0.44.0 # LGPLv2+
tripleo-common>=12.2.0 # Apache-2.0
cryptography>=2.1 # BSD/Apache-2.0
futures>=3.0.0;python_version=='2.7' or python_version=='2.6' # BSD
ansible-runner>=1.4.4 # Apache 2.0

+ 3
- 3
setup.cfg View File

@ -7,6 +7,7 @@ license = Apache License, Version 2.0
author = OpenStack
author-email = openstack-discuss@lists.openstack.org
home-page = https://docs.openstack.org/python-tripleoclient/latest/
python-requires = >=3.6
classifier =
Environment :: Console
Environment :: OpenStack
@ -16,6 +17,8 @@ classifier =
License :: OSI Approved :: Apache Software License
Operating System :: OS Independent
Programming Language :: Python
Programming Language :: Python :: Implementation :: CPython
Programming Language :: Python :: 3 :: Only
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
@ -24,9 +27,6 @@ classifier =
packages =
tripleoclient
[wheel]
universal = 1
[compile_catalog]
directory = tripleoclient/locale
domain = tripleoclient


+ 0
- 9
setup.py View File

@ -13,17 +13,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
# In python < 2.7.4, a lazy loading of package `pbr` will break
# setuptools if some other modules registered functions in `atexit`.
# solution from: http://bugs.python.org/issue15881#msg170215
try:
import multiprocessing # noqa
except ImportError:
pass
setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)

Loading…
Cancel
Save