Add lint dependencies for content provider

If linting fails, content provider still builds.
Whis is suboptimal, since standalone/multinode jobs will be skipped and
nothing will use those builds.

Put cprovider into dependency on the linting jobs as well.

Change-Id: Icdd2c581c8e610eb687042044c2a8f3efee44527
Signed-off-by: Bogdan Dobrelya <bdobreli@redhat.com>
changes/17/770917/1
Bogdan Dobrelya 2 years ago
parent 34dccbccc2
commit 9014c68e60
  1. 25
      zuul.d/layout.yaml

@ -13,7 +13,11 @@
- tripleo-upgrades-master-pipeline
check:
jobs:
- tripleo-ci-centos-8-content-provider
- tripleo-ci-centos-8-content-provider:
dependencies:
- openstack-tox-pep8
- openstack-tox-py36
- openstack-tox-py37
- tripleo-ci-centos-8-containers-multinode:
vars: &multi_consumer_vars
consumer_job: true
@ -30,10 +34,7 @@
- overcloud-deploy
- overcloud-post-deploy
- overcloud-validate
dependencies: &deps_unit_lint_cprovider
- openstack-tox-pep8
- openstack-tox-py36
- openstack-tox-py37
dependencies: &cprovider
- tripleo-ci-centos-8-content-provider
- tripleo-ci-centos-8-standalone:
vars: &sa_consumer_vars
@ -41,22 +42,22 @@
build_container_images: false
tags:
- standalone
dependencies: *deps_unit_lint_cprovider
dependencies: *cprovider
- tripleo-ci-centos-8-scenario000-multinode-oooq-container-updates:
vars: *multi_consumer_vars
dependencies: *deps_unit_lint_cprovider
dependencies: *cprovider
- tripleo-ci-centos-8-scenario001-standalone:
vars: *sa_consumer_vars
dependencies: *deps_unit_lint_cprovider
dependencies: *cprovider
- tripleo-ci-centos-8-scenario002-standalone:
vars: *sa_consumer_vars
dependencies: *deps_unit_lint_cprovider
dependencies: *cprovider
- tripleo-ci-centos-8-scenario003-standalone:
vars: *sa_consumer_vars
dependencies: *deps_unit_lint_cprovider
dependencies: *cprovider
- tripleo-ci-centos-8-scenario004-standalone:
vars: *sa_consumer_vars
dependencies: *deps_unit_lint_cprovider
dependencies: *cprovider
- tripleo-ci-centos-8-containers-undercloud-minion:
vars: &undercloud_consumer_vars
consumer_job: true
@ -65,7 +66,7 @@
- undercloud-scripts
- undercloud-install
- undercloud-validate
dependencies: *deps_unit_lint_cprovider
dependencies: *cprovider
files:
- ^config-generator/.*minion.*$
- ^tripleoclient/config/.*minion.*$

Loading…
Cancel
Save