Browse Source

Updated from global requirements

Change-Id: I35cb1e82ff24b7180f8ed1671ad01c7acf262a3c
OpenStack Proposal Bot 2 years ago
parent
commit
d7ac0ff7ca
2 changed files with 15 additions and 3 deletions
  1. 11
    2
      setup.py
  2. 4
    1
      test-requirements.txt

+ 11
- 2
setup.py View File

@@ -1,4 +1,4 @@
1
-#!/usr/bin/env python
1
+# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
2 2
 #
3 3
 # Licensed under the Apache License, Version 2.0 (the "License");
4 4
 # you may not use this file except in compliance with the License.
@@ -13,8 +13,17 @@
13 13
 # See the License for the specific language governing permissions and
14 14
 # limitations under the License.
15 15
 
16
+# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
16 17
 import setuptools
17 18
 
19
+# In python < 2.7.4, a lazy loading of package `pbr` will break
20
+# setuptools if some other modules registered functions in `atexit`.
21
+# solution from: http://bugs.python.org/issue15881#msg170215
22
+try:
23
+    import multiprocessing  # noqa
24
+except ImportError:
25
+    pass
26
+
18 27
 setuptools.setup(
19
-    setup_requires=['pbr'],
28
+    setup_requires=['pbr>=2.0.0'],
20 29
     pbr=True)

+ 4
- 1
test-requirements.txt View File

@@ -1 +1,4 @@
1
-hacking>=0.12.0,!=0.13.0,<0.14  # Apache-2.0
1
+# The order of packages is significant, because pip processes them in the order
2
+# of appearance. Changing the order has an impact on the overall integration
3
+# process, which may cause wedges in the gate later.
4
+hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0

Loading…
Cancel
Save