Browse Source

Bump flask to past 1.0 (current 1.0.2)

Flask has move to 1.0 and is quite stable. New in 1.0+ is a lot
of beneficial test bits among other generally nice changes. In
moving Keystone to Flask, we would like to lean on the new test
capabilities in 1.0+

Change-Id: Ie0e8984c4c02a426eb1e7cbac8c5117aaaff5c40
changes/34/577534/4
Morgan Fainberg 4 years ago
parent
commit
cb6c00c01f
  1. 2
      global-requirements.txt
  2. 4
      lower-constraints.txt
  3. 2
      upper-constraints.txt

2
global-requirements.txt

@ -58,7 +58,7 @@ eventlet!=0.18.3,!=0.20.1,!=0.21.0,!=0.23.0 # MIT
exabgp # BSD
extras # MIT
falcon # Apache-2.0
Flask!=0.11,<1.0 # BSD
Flask!=0.11 # BSD
flask-keystone # Apache-2.0
flask-oslolog # Apache-2.0
Flask-RESTful # BSD

4
lower-constraints.txt

@ -455,7 +455,7 @@ watchdog===0.8.3
gevent===1.2.2
os-vif===1.7.0
python-masakariclient===3.0.1
Werkzeug===0.9
Werkzeug===0.14
pyasn1-modules===0.0.6
APScheduler===3.4.0
pip===8.0.3
@ -505,7 +505,7 @@ greenlet===0.4.10
xvfbwrapper===0.1.3
futures===3.0.0
tosca-parser===1.0.0
Flask===0.10
Flask===1.0.2
pymod2pkg===0.7.0
happybase===0.5
marathon===0.8.6

2
upper-constraints.txt

@ -509,7 +509,7 @@ XStatic-Angular-Vis===4.16.0.0
xvfbwrapper===0.2.9
futures===3.2.0;python_version=='2.7'
tosca-parser===1.0.0
Flask===0.12.4
Flask===1.0.2
happybase===1.1.0;python_version=='2.7'
marathon===0.9.3
fasteners===0.14.1

Loading…
Cancel
Save