Browse Source

Remove version pbr pins from setup_requires

* setuptools can never upgrade things based on setup_requires versions
* actual pbr version range should be defined in requirements.txt

Change-Id: Ia7d4287c098b98c63eac8fca85237410a9ec8cea
Sergey Lukjanov 5 years ago
parent
commit
c3ef37253f
2 changed files with 2 additions and 1 deletions
  1. 1
    0
      requirements.txt
  2. 1
    1
      setup.py

+ 1
- 0
requirements.txt View File

@@ -0,0 +1 @@
1
+pbr>=0.5.21,<1.0

+ 1
- 1
setup.py View File

@@ -18,5 +18,5 @@
18 18
 import setuptools
19 19
 
20 20
 setuptools.setup(
21
-    setup_requires=['pbr>=0.5.21,<1.0'],
21
+    setup_requires=['pbr'],
22 22
     pbr=True)

Loading…
Cancel
Save