Browse Source

Use unittest.mock instead of mock

The mock third party library was needed for mock support in py2
runtimes. Since we now only support py36 and later, we can use the
standard lib unittest.mock module instead.

Change-Id: Ib8c30a3357c57f9c127b94d777610d602454e0ef
changes/46/734546/2
Hervé Beraud 4 weeks ago
parent
commit
a0f41eea53
4 changed files with 3 additions and 4 deletions
  1. +0
    -1
      lower-constraints.txt
  2. +2
    -1
      sahara_plugin_storm/tests/unit/base.py
  3. +1
    -1
      sahara_plugin_storm/tests/unit/plugins/storm/test_plugin.py
  4. +0
    -1
      test-requirements.txt

+ 0
- 1
lower-constraints.txt View File

@@ -57,7 +57,6 @@ Mako==1.0.7
MarkupSafe==1.1.0
mccabe==0.5.3
microversion-parse==0.2.1
mock==2.0.0
monotonic==1.5
mox3==0.26.0
msgpack==0.6.1


+ 2
- 1
sahara_plugin_storm/tests/unit/base.py View File

@@ -13,7 +13,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.

import mock
from unittest import mock

from oslotest import base

from sahara import context


+ 1
- 1
sahara_plugin_storm/tests/unit/plugins/storm/test_plugin.py View File

@@ -13,7 +13,7 @@
# See the License for the specific language governing permissions and
# limitations under the License.

import mock
from unittest import mock

from sahara.plugins import base as pb
from sahara.plugins import conductor


+ 0
- 1
test-requirements.txt View File

@@ -9,7 +9,6 @@ bashate>=0.5.1 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
doc8>=0.6.0 # Apache-2.0
fixtures>=3.0.0 # Apache-2.0/BSD
mock>=2.0.0 # BSD
oslotest>=3.2.0 # Apache-2.0
stestr>=1.0.0 # Apache-2.0
pylint==1.4.5 # GPLv2


Loading…
Cancel
Save