Browse Source

Add framework for sahara-status upgrade check

This commit adds the functionality of sahara-status CLI for performing
upgrade checks as part of the Stein cycle upgrade-checkers goal.
It only includes a sample check which must be replaced by real checks in
future.

Change-Id: Idcb8d9eaf689800812cf6087e9c5937058c89ea6
Story: 2003657
Task: 26152
changes/83/629183/1
akhiljain23 3 years ago
committed by Matt Riedemann
parent
commit
5dd969dcca
  1. 1
      requirements.txt
  2. 1
      setup.cfg

1
requirements.txt

@ -27,6 +27,7 @@ oslo.policy>=1.30.0 # Apache-2.0
oslo.rootwrap>=5.8.0 # Apache-2.0
oslo.serialization!=2.19.1,>=2.18.0 # Apache-2.0
oslo.service!=1.28.1,>=1.24.0 # Apache-2.0
oslo.upgradecheck>=0.1.0 # Apache-2.0
oslo.utils>=3.33.0 # Apache-2.0
paramiko>=2.0.0 # LGPLv2.1+
requests>=2.14.2 # Apache-2.0

1
setup.cfg

@ -41,6 +41,7 @@ console_scripts =
_sahara-subprocess = sahara.cli.sahara_subprocess:main
sahara-templates = sahara.db.templates.cli:main
sahara-image-pack = sahara.cli.image_pack.cli:main
sahara-status = sahara.cli.sahara_status:main
wsgi_scripts =
sahara-wsgi-api = sahara.cli.sahara_api:setup_api

Loading…
Cancel
Save