Browse Source

Migrate grenade jobs to py3

As part of community goal of dropping py27 support[1], we are
moving the devstack to py3 by default[2]. That will make grenade job
to perform upgrade from py2 to py3 which will not work (we have seen
the failure in neutron-grenade job).

To avoid existing grenade py2 job break, this commit moves grenade
jobs to py3 which is what we planned as part dropping the py2 support.

[1] https://governance.openstack.org/tc/goals/selected/ussuri/drop-py27.html
[2] https://review.opendev.org/#/c/649097/12
    http://lists.openstack.org/pipermail/openstack-discuss/2019-November/010938.html

Change-Id: I1a0018dd164ccdab803b67c5883d3f28819bd45d
changes/95/695095/1
Ghanshyam Mann 2 weeks ago
parent
commit
d4bdcecc07
1 changed files with 1 additions and 0 deletions
  1. +1
    -0
      playbooks/sahara-grenade/run.yaml

+ 1
- 0
playbooks/sahara-grenade/run.yaml View File

@@ -60,6 +60,7 @@
export DEVSTACK_GATE_TEMPEST=1
export DEVSTACK_GATE_TEMPEST_REGEX="sahara_tempest_plugin.tests.api"
export DEVSTACK_GATE_GRENADE=pullup
export DEVSTACK_GATE_USE_PYTHON3=True
export BRANCH_OVERRIDE=default
if [ "$BRANCH_OVERRIDE" != "default" ] ; then
export OVERRIDE_ZUUL_BRANCH=$BRANCH_OVERRIDE

Loading…
Cancel
Save