Browse Source

Fix the lower-requirements job: libpq-dev, psycopg 2.7

- Add libpq-dev to bindep.txt
  Apparently this is needed after some unclear change.
  Without this, psycopg fails to install:
  "You need to install postgresql-server-dev-X.Y for building a server-side
  extension or libpq-dev for building a client-side application."

- Bump the minimum version of psycopg to 2.7.2
  pysycopg 2.6.2 is not able to deal with PostgreSQL 10:
  "Error: could not determine PostgreSQL version from '10.6'"

Thanks to https://review.openstack.org/643231

Change-Id: If4ecc6a80bed338a0117adee0e6d361c135d9123
Luigi Toscano 1 month ago
parent
commit
f0a1cc99d0
3 changed files with 3 additions and 2 deletions
  1. 1
    0
      bindep.txt
  2. 1
    1
      lower-constraints.txt
  3. 1
    1
      test-requirements.txt

+ 1
- 0
bindep.txt View File

@@ -17,6 +17,7 @@ mysql-client [platform:dpkg]
17 17
 mysql-server [platform:dpkg]
18 18
 postgresql
19 19
 postgresql-client [platform:dpkg]
20
+libpq-dev [platform:dpkg]
20 21
 postgresql-server [platform:rpm]
21 22
 
22 23
 # The Python binding for libguestfs are used by the sahara-image-pack

+ 1
- 1
lower-constraints.txt View File

@@ -95,7 +95,7 @@ pbr==2.0.0
95 95
 pika-pool==0.1.3
96 96
 pika==0.10.0
97 97
 prettytable==0.7.2
98
-psycopg2==2.6.2
98
+psycopg2==2.7.3
99 99
 pyasn1==0.4.2
100 100
 pycadf==2.7.0
101 101
 pycparser==2.18

+ 1
- 1
test-requirements.txt View File

@@ -13,7 +13,7 @@ fixtures>=3.0.0 # Apache-2.0/BSD
13 13
 mock>=2.0.0 # BSD
14 14
 oslotest>=3.2.0 # Apache-2.0
15 15
 stestr>=1.0.0 # Apache-2.0
16
-psycopg2>=2.6.2 # LGPL/ZPL
16
+psycopg2>=2.7.3 # LGPL/ZPL
17 17
 pylint==1.4.5 # GPLv2
18 18
 testresources>=2.0.0 # Apache-2.0/BSD
19 19
 testscenarios>=0.4 # Apache-2.0/BSD

Loading…
Cancel
Save