Browse Source

Fix hacking min version to 3.0.1

flake8 new release 3.8.0 added new checks and gate pep8
job start failing. hacking 3.0.1 fix the pinning of flake8 to
avoid bringing in a new version with new checks.

Though it is fixed in latest hacking but 2.0 and 3.0 has cap for
flake8 as <4.0.0 which mean flake8 new version 3.9.0 can also
break the pep8 job if new check are added.

To avoid similar gate break in future, we need to bump the hacking min
version.

Also removing the hacking and other related dep from lower-constraints file
as theose are blacklisted requirements and does not need to be present
there.

- http://lists.openstack.org/pipermail/openstack-discuss/2020-May/014828.html

Change-Id: Idd108d9575b276f3d78a7c3c6dbc5f3ed3205411
changes/80/728980/1
Ghanshyam Mann 3 months ago
parent
commit
29d84ca4eb
2 changed files with 1 additions and 4 deletions
  1. +0
    -3
      lower-constraints.txt
  2. +1
    -1
      test-requirements.txt

+ 0
- 3
lower-constraints.txt View File

@@ -25,13 +25,11 @@ eventlet==0.18.2
extras==1.0.0
fasteners==0.14.1
fixtures==3.0.0
flake8==3.7.9
future==0.16.0
futurist==1.6.0
gitdb2==2.0.3
GitPython==2.1.8
greenlet==0.4.13
hacking==2.0.0
idna==2.6
iso8601==0.1.12
Jinja2==2.10
@@ -89,7 +87,6 @@ pyasn1==0.4.2
pycadf==2.7.0
pycparser==2.18
pycodestyle==2.5.0
pyflakes==1.0.0
pyinotify==0.9.6
PyMySQL==0.7.6
PyNaCl==1.2.1


+ 1
- 1
test-requirements.txt View File

@@ -3,7 +3,7 @@
# process, which may cause wedges in the gate later.

# Hacking already pins down pep8, pyflakes and flake8
hacking>=3.0,<4.0.0 # Apache-2.0
hacking>=3.0.1,<3.1.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
mock>=2.0.0 # BSD
oslotest>=3.2.0 # Apache-2.0


Loading…
Cancel
Save