Browse Source

Minor cleanup to test publishing

Remove now obsolete python 2.7.x support from setup.py,
update pbr version and make dependency explicit via requirements.txt

This change was pushed to test that the dependent change fixes
publishing content to https://service-types.openstack.org/ . So,
please merge once dependency is in and then we can check that publishing
to server works correctly.

Depends-On: https://review.opendev.org/709060
Change-Id: Iac2be67dbef5510679f5cda658b591e52d537051
changes/62/709062/2
Andreas Jaeger 11 months ago
parent
commit
37984a6273
2 changed files with 2 additions and 10 deletions
  1. +1
    -0
      requirements.txt
  2. +1
    -10
      setup.py

+ 1
- 0
requirements.txt View File

@@ -1,3 +1,4 @@
pbr!=2.1.0,>=2.0.0 # Apache-2.0
hacking
jsonschema
requests


+ 1
- 10
setup.py View File

@@ -13,17 +13,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.

# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools

# In python < 2.7.4, a lazy loading of package `pbr` will break
# setuptools if some other modules registered functions in `atexit`.
# solution from: http://bugs.python.org/issue15881#msg170215
try:
import multiprocessing # noqa
except ImportError:
pass

setuptools.setup(
setup_requires=['pbr>=1.8'],
setup_requires=['pbr>=2.0.0'],
pbr=True)

Loading…
Cancel
Save